webix.print returns error

When I do webix.print, I get an error:

Uncaught TypeError: this.getSpan is not a function webix debug.js:26085

This is using the cdn edge webix.

You can see my (very skeletal) app at


Click the Reports tab, then click the print icon on the upper right.


  • Hello,

    I can confirm the issue, thank you for reporting. We will fix it in the next 5.2 update.

    As the issue occurs only in the GPL edition of the library (the one available on cdn) you can get a free trial version of the PRO edition as a temporary solution.

  • I still get an error with the trial version (which I downloaded last month). The error is

    Uncaught TypeError: window.print is not a function at Webix debug.js 16571

    The download version is 5.1.4 if that helps. Is there a newer trial download I could use?

  • Please, check the following snippet: https://webix.com/snippet/52296f77

    It works fine with the latest Pro (Commercial) version, 5.1.4 will do the job as well. The bug is in the free GPL version and it will be fixed in the next release (5.2).

  • Your snippet works for me. But I have exactly that code, and even when using the downloaded trial version, it doesn't work for me. Same error. I may need to wait for 5.2 ... any idea when that might be? I still have lots to do with this, so no hurry.

  • I think the issue is with views that are inside a multi-view. When I create a page with just the report and a print button, like your snippet, printing works with the downloaded webix (not the CDN version). But when the report is in a multiview, that is when I get the "window.print is not a function" error. So the multiview seems to be causing a problem as well.

  • Hello,

    window.print is not a function at Webix debug.js 16571

    It can be a browser-related issue. Could you please specify the browser/device in use?

  • I am using Chrome 63.0.3239.132 on Mac OS.

  • But this only happens when I try to print a datatable that is in a multi-view. If I remove the multi-view and have the datatable alone, then printing works. So I think it's something to do with the multi-view.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!