spreadsheet setFormat invalid with webix 6

edited November 2018 in Technical questions

Hello! webix team,
I find the setFormat method of Spreadsheet is invalid with webix version 6, but previous version is valid and it can work with menu. Is this bug?

https://snippet.webix.com/jbgzacu1

Comments

  • Hello @Karena !

    Yeap, it's a bug. We will fix it. Thank you for the report!

  • edited November 2018

    Hello, webix team!
    I have another problem about spreadsheet.
    I set the percent format with webix version 5.4.0. It can work.

    $$("ssheet").setFormat(3, 6, "[<0]-0.00%;[>=0]0.00%");
    $$("ssheet").setFormat(3, 6, "[<0]-0%;[>=0]0%");

    When I export to excel then import the excel to spreadsheet, the percent format would not be imported.
    I also use the $$("ssheet").serialize() to save json text to my database, it cannot load this rule ("[<0]-0.00%;[>=0]0.00%"), but another rule ("[<0]-0%;[>=0]0%") can.

    How can I fix it? Will the new webix version be updated soon?
    Thanks!

    https://snippet.webix.com/tilldnc6

  • Hi @Karena

    Exporting of number formats to excel is not supported.

    There was a bug with loading and saving number formats in Webix 5.4, in Webix 6.0 it was fixed.

    As for "[<0]-0%;[>=0]0%" format, there are some predefined formats for currency, number and percent, they are stored in styles (percent, int, price).

  • Hi @Karena

    I can recommend you to upgrade Webix to version 6.1, the setFormat bug has been fixed.

  • @Dima_S I've checked the snippet. But setFormat method still didn't work.
    https://snippet.webix.com/prhugcdf

  • edited November 2018

    Hi @Karena

    Please clear the cache and check the snippet again, on my side it works fine. If it still doesn't work, could you please clarify what exactly goes wrong?

  • edited November 2018

    @Dima_S Thank you for your help! After I clear the cache, it works. ^_^

  • edited December 2018

    Hello @Dima_S
    I tried the format of spreadsheet with webix6.1 which is downloaded by webix client.
    When I set two "Decimal places" of the number format, the decimal point will be comma. (Like this "[<0]-0,##%;[>=0]0,##%")
    For example, I use the percent format for 0.1118 and the data will be 11,18%.
    If I change the comma to decimal point, the value will be 011.%.
    I also tried the format with snippet, it doesn't have any problem.
    Does version 6.1 of library in webix client have problem?

  • edited December 2018

    Hi @Karena

    You should pay attention, that from webix 6.1 group and decimal delimiters are taken from the locale, so if in your locale "." is not a group or decimal delimiter it will be added as text.

  • @Dima_S I appreciate you kind reply to my question. The problem has been solved.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!