Evaluating webix : 1.6.5. webix-jet 1.6.3-m ($$ returning null value) in Typescript

Yesterday, I update the webix version to 1.6.5 after that $$ is returning null value

I have tried importing webix using both
import * as webix from 'webix' and
import (ui, $$) from 'webix'

For eg. $$("firstview") return null. This was not the case in earlier version.

Also, I have another issue in tabview I use the following code to addview dynamically add view as a tab, but when I close the tab, the view is not removed/destroyed.

   tabview.addView(
    {
      id: _viewname, header:_headervalue
      body: { id: _viewid, $subview: _componentname },
      close: true
    }

Comments

  • I also tried using webix.$$("firstview") it still returns null

  • It possible that you have two webix instances - the global one ( script tag with webix.js ), and the imported one. In such case the widgets created with one instance will not be other one.

    Be sure that you are including webix only in one way.

    Also, I have another issue in tabview

    Webix Jet patches the core Webix library to be able to detect such operations.
    Issue can also be caused by multiple instances of webix library

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion