Error with load spreadsheet

I tried to load the spreadsheet by Url like it shows off in this example https://snippet.webix.com/l13icd2f

My code it this(I have 6.2.8 version of Webix)

var url = "binary->https://docs.webix.com/samples/65_spreadsheet/common/test.xlsx";

webix.ready(function(){
webix.ui({
container:"dataSheet",
rows:[
{
view:"toolbar",
id:"myToolbarExcel",
height:45,
cols:[
{ view:"toggle", type:"iconButton", icon:"mdi mdi-content-save-outline", label:"Guardar Configuración", click: guardarConfig, inputWidth: "200" }
]
},
{
view:"spreadsheet",
id:"SheetId",
toolbar:"full",
liveEditor:true,
bottombar:true,
url: url,
datatype:"excel"
}
]
});
});

and when I load my page this error appears.

TypeError: Cannot create property '_inner' on number 'NaN'
at result._beforeResetBorders (webix.js:20793)
at result._parse_cells (webix.js:20713)
at new result (webix.js:2166)
at new t (webix.js:2110)
at Function._view (webix.js:2049)
at result._parse_cells (webix.js:20411)
at result._parse_cells (webix.js:20715)
at new result (webix.js:2166)
at _view (webix.js:2060)
at _ui_creator (webix.js:1940)

Tagged:

Comments

  • Hey @JamesHernandez, unfortunately i couldn't reproduce your issue, I've tried basically the same config on different versions, please take a look at this snippet: https://snippet.webix.com/o9o3pdme. The only real issue here might be that your container is probably not defined in the html, or you are referencing a wrong container, otherwise this snippet should work just fine with our example data.
    Could you please provide an example with your code, using your html container?

  • edited July 10

    Sure! This's my html code.

    div class="wrapper wrapper-content animated fadeInRight">
    div class="row">
    div class="ibox float-e-margins">
    div class="ibox-content">
    div class="mb-sm clearfix">
    div class="webix_view">
    div id="dataSheet" class="div">
    /div>
    /div>
    /div>
    /div>
    /div>
    /div>

  • edited July 11

    Hi again @JamesHernandez, I'm still having troubles with reproducing your issue, please take a look at this, it's working as expected: https://snippet.webix.com/f1i5qzs2. I've used your code exactly in this example minus the click: guardarConfig, since I don't have access to this info (so the issue might be in there somewhere).
    I would like to know whether the code you provided was the full example you were trying to get working, or did you leave out some parts of the code? If you did leave out something, it would be really helpful if you could provide your own example via the snippet tool.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!