Problem with Desktop webix app

edited July 24 in General

Hi, i got this error when I tried to use my webix desktopApp with Node js:
Uncaught SyntaxError: Unexpected token <
here is my code:
<!DOCTYPE html>



<script src="//cdn.webix.com/site/webix.js" type="text/javascript" charset="utf-8"></script>

<!-- Componentes escritorio -->
<script src="js/app.js" type="text/javascript"></script>
<script src="js/wins.js" type="text/javascript"></script>
<script src="js/data.js" type="text/javascript"></script>
<!-- Mapas -->
<script src="//cdn.webix.com/components/edge/openmap/openmap.js"></script>
<link rel="stylesheet" href="https://unpkg.com/leaflet@1.5.1/dist/leaflet.css"
    integrity="sha512-xwE/Az9zrjBIphAcBb3F6JVqxf46+CDLwfLMHloNu6KEQCAWi6HcDUbeOfBIptF7tcCzusKFjFw2yuvEpDL9wQ=="
    crossorigin="" />
<!-- Material Design Icons -->
<link rel="stylesheet" type="text/css" href="//cdn.materialdesignicons.com/2.7.94/css/materialdesignicons.css">
<title>Webix Desktop App</title>



var desktopApp = {
buttonCount: 1,
//#region Inicio de la pagina web
init: function () {
webix.env.codebase = "./";
this.createLayout();
this.createToolbar();
this.startTime();
this.createMenu();
this.signOut();
$$("limit").setValue(attemps);
},
//#endregion
//more code here:
};

I´m using this Windows-like web UI

Comments

  • edited July 25

    Hey @Hellekin, I'm assuming you are talking about this demo? I've tried downloading it and launching locally, everything worked just fine. Looking at your code it seems that you've most likely made a few modifications to the original demo.

    Could you please specify your use case a little bit more and maybe provide your modified demo in some way? Also, judging from the error log it seems to be a simple syntax error somewhere in the code, although I can't really confirm that yet.

  • edited July 25

    Hi @Dzmitry, I can manage to fix the problem, I just cleaned the cache from my computer and add "var desktopApp" but now i get another problem, i can't see the wallpaper and the window button, but the "sign in" part and my other components work fine, thanks for your time and your help.

  • I reply this comment with the solution of the previous question. I only had to change src for href when I call styles.css

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion