datatable table head Offset when zoom out

if there are many cols in the datatable (such as 1000),once you zoom it out, an offset will appear between the table head and the table body.why is that and how can solve it.Any advise will be grateful.

Comments

  • can you provide a snippet?
    in this one I can't see any problem.
    https://snippet.webix.com/26xoz0n4

  • add this {css:"webix_header_border webix_data_border"},when I zoom out you snippet to 67%, the offset between table head and table body will appear.

  • especially in the middle of a row,the offset is unacceptable。Thanks for your replay.

  • yes, I see what you mean.
    I think that is because of difference between head and data html representations. Head is DOM Table, while data is divs.
    To avoid such behavior at zoom, all of structure should be unified.
    Either table or divs.
    But in this case some more important options would be lost.

  • edited October 9

    Hello @Dudadi,

    Unfortunately, this is a known issue with the header shift on various zoom levels, and so far it cannot be fixed without a full rework of the component’s structure.

    The only way to reduce the offset is to set the width of columns as a multiple of 20. It will do the trick for the most of the zoom scales for all browsers (with two major exceptions for prime numbers - 33% and 67%): https://snippet.webix.com/x4dj15f8 (as you can see, the offset is still there, but is slightly less pronounced).

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!