Invalid Host/Origin header

After changing from webix jet 5 to 7 I constantly see the following errors scrolling in the console (using chrome):

Invalid Host/Origin header index.js:167
[WDS] Disconnected! index.js:172

What do I need to do do to get rid of those errors?

Thanks,
Pieter.

Comments

  • Hello @Pieter,

    What do I need to do do to get rid of those errors?

    I'm not quite sure what version of Webix Jet you are running on, since you've stated versions 5 and 7 - Webix Jet has its own release schedule and does not depend on the core library releases (mostly). The latest version of Webix Jet as of now is 2.1.2. Could you please provide the exact steps you've taken to update your Webix Jet?

    As for the error itself, it looks like an issue with Webpack, specifically with the dev-server module (https://github.com/webpack/webpack-dev-server/issues/1604). If that is the case, the issue has been fixed for a while now, and the latest version should work fine (you could also try the workaround mentioned in the GitHub post). Could you please provide all of the dependencies listed in the package.json file and their versions?

  • edited December 3

    package.json is as follows:

    {
      "name": "webix-jet-app",
      "version": "1.1.0",
      "description": "Webix Jet App",
      "main": "sources/myapp.js",
      "scripts": {
        "test": "echo \"Error: no test specified\" && exit 1",
        "lint": "eslint sources/",
        "build": "webpack --env.production true",
        "module": "webpack --env.production true --env.module true",
        "standalone": "webpack --env.production true --env.module true --env.standalone true",
        "start": "webpack-dev-server --host sbsdev --port 8101"
      },
      "keywords": [
        "webix",
        "jet"
      ],
      "license": "MIT",
      "devDependencies": {
        "babel-core": "^6.26.0",
        "babel-loader": "^7.1.2",
        "babel-plugin-syntax-dynamic-import": "^6.18.0",
        "babel-plugin-transform-object-rest-spread": "^6.26.0",
        "babel-preset-env": "^1.6.0",
        "css-loader": "^0.28.7",
        "eslint": "^4.7.2",
        "file-loader": "^0.11.2",
        "less": "^2.7.2",
        "less-loader": "^4.0.5",
        "mini-css-extract-plugin": "^0.4.0",
        "url-loader": "^0.5.9",
        "webpack": "^4.12.1",
        "webpack-cli": "^3.0.8",
        "webpack-dev-server": "^3.1.4"
      },
      "dependencies": {
        "@xbs/filemanager": "^7.0.5",
        "@xbs/kanban": "^7.0.5",
        "@xbs/pivot": "^7.0.5",
        "@xbs/scheduler": "^7.0.5",
        "@xbs/spreadsheet": "^7.0.5",
        "@xbs/webix-pro": "^7.0.5",
        "webix-jet": "^2.0.4"
      }
    }
    
  • Thanks for the information @Pieter.

    Have you tried any of the workarounds provided in the GH issues thread (i.e. setting disableHostCheck: true in your Webpack config inside of the devServer property)? Also, as previously mentioned, could you please provide the exact steps you've taken to update your Webix Jet? Alternatively, you could also try updating your dependencies (be sure to back them up first just in case).

  • Setting the disableHostCheck property did the trick!
    Thank you for your help!
    Pieter

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!