How to do webix jet navigation?

Hi,

I am getting an error in webix jet when I navigate the URL.

The first URL is this => http://localhost:8080/#!/navigationBar/topSideBar/appslist

There is a button to call the next view, After I click the button next view URL(second URL) will => http://localhost:8080/#!/navigationBar/qtoApplication Then when I go back(by browser back button) to the first URL view, I got the below error, Url is changed but the view is not changing. I cannot go back to the first URL view.

I tried to add a button at the second URL view in order to go back to the first URL. It is also got the same error as per below.

I used navigationBar view as a top view, the rest is a subview.

I would like to know How to do correct navigation.

Thanks in Advance

myapp.js:9836 TypeError: Cannot read property 'linkInput' of undefined
at result._init_onchange (webix.js:30753)
at result.callEvent (webix.js:729)
at result.render (webix.js:2736)
at result.render (webix.js:28077)
at result.$setSize (webix.js:30618)
at result._set_child_size (webix.js:20648)
at result._set_child_size (webix.js:20752)
at result.$setSize (webix.js:20743)
at result._set_child_size (webix.js:20635)
at result._set_child_size (webix.js:20752)

This is my application.
// myapp.js
import { JetApp, EmptyRouter, HashRouter } from "webix-jet";

export default class MyApp extends JetApp {
constructor(config) {
const defaults = {
router: BUILD_AS_MODULE ? EmptyRouter : HashRouter,
debug: !PRODUCTION,
start: "/navigationBar/topSideBar/projects"
};

    super({ ...defaults, ...config });
}

}

if (!BUILD_AS_MODULE) {
webix.ready(() => {
if (webix.CustomScroll){
webix.CustomScroll.init();
}
new MyApp().render();
});
}

Comments

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion