Please open sample by http, not as file://

I'm just getting started learning web programming and have a stupid question.

When I open my Webix app in firefox by pointing it to the html file in my project directory, I get a popup message in the upper right corner that says "Please open sample by http, not as file://".

How do I host it via http while I am developing the app?

Comments

  • You need to run a web server locally. For example, you can do this by running the Apache Web Server app via XAMPP or something like that.

    https://www.apachefriends.org/index.html

    Here's a step-by-step guide:

    https://blog.udemy.com/xampp-tutorial/

  • How to disable this popup? I run webix from Electron, so my app will never be opened by http

  • Has there ever been an answer to this? Facing the same issue

  • Hi @joelhoro

    In a regular browser, if an HTML page is opened as file://, it restricts access to external resources.
    The checkup for document.location.href is obligatory, does not produce anything except this warning, and appears only in the debug version of the library (which contains a set of similar statements for the most common issues). We highly recommend using this version of Webix during development.

    However, it will not appear in the minified (production) version of the script (webix.min.js).

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!