Auto Fill password filed through browser's saved passowrd.


I want to stop auto filled password text field in webix form which is filled through browser’s saved data.


It’s possible to provide attribute via the related attributes property of a text control, which allows settings any HTML attribute to an input:

view:"text", { attributes:{ autocomplete:"off" }}

If you want to disable autocompleting for all the element in a form at once, you can use the form’s **elementsConfig**setting:

view:"form", elementsConfig:{

Please, check the related snippet:

Also, as another way you can add autocomplete: "new-password"

Its not working if user’s browser has enabled autofill option.

Please check this snippet -

Here, username and password will filled automatically by browser’s saved username and password.

The above solution must work correctly in Chrome/Safari. And there is an open issue for Firefox support

The solution provided by @Nastja allows to define any attribute for the HTML input, so if you have any other solution which works with raw HTML you can use it with Webix control as well.

This has no effect in my case

Hi @bikerboy can you please provide a snippet ? thank you